nix-config/modules/pipewire.nix
2025-04-07 18:19:32 +02:00

21 lines
634 B
Nix

{ pkgs, ... }:
{
# Enable sound with pipewire.
#sound.enable = true;
hardware.pulseaudio.enable = false;
environment.systemPackages = with pkgs; [ pamixer ];
services.pipewire = {
enable = true;
#alsa.enable = true;
#alsa.support32Bit = true;
#pulse.enable = true;
# If you want to use JACK applications, uncomment this
#jack.enable = true;
# use the example session manager (no others are packaged yet so this is enabled by default,
# no need to redefine it in your config for now)
#media-session.enable = true;
};
}