nix-config/modules/openssh.nix
2025-04-03 12:50:08 +02:00

14 lines
322 B
Nix

{ pkgs, ... }:
{
# Enable the OpenSSH daemon.
services.openssh = {
enable = true;
settings = {
X11Forwarding = true;
PermitRootLogin = "no"; # disable root login
PasswordAuthentication = false; # disable password login
};
openFirewall = true;
};
}